Upgrade from 7.1.0 to 7.1.3


#1

Just want to verify how to upgrade to 7.1.3. from 7.1.0. I have several sites sharing the same core.
Do I just follow the instructions at How do you upgrade from FarCry 6.x to FarCry 7 (codename: SHINY)? ?

Also, I can’t seem to find any information on the 7.1.3 release.

Thanks,

  • JR

#2

When you’re updating Core with the same “minor” version but a different “patch” version – e.g. 7.1.0 to 7.1.3 – all you should need to do is update the Core files and then restart the application (i.e. ?updateapp=<your-app-key> or Update Application from the webtop profile menu).

If you upgrade to a newer “minor” version – e.g. 7.1.0 to 7.2.1 – then you will need to update the Core files, restart the application, and possibly deploy some schema changes. You can do this with ?updateall=<your-app-key> or in the webtop via Admin -> Developer Tools -> COAPI Content Types.


#3

A “patch” release like 7.1.0-7.1.3 should require no project based code changes or database schema changes.

To do a maintenance upgrade you typically:

  • replace the ./core files with the later version
  • restart the application; for example, ?updateapp=projectkey

Some things to look out for, particularly in shared environments:

  • the web server may not let you replace the files (for example, IIS); you may need to stop the web server prior to replacing the files
  • for old school server deploys, we typically do this with a git pull
  • backup before doing an upgrade (though a maintenance patch should represent minimal risk on the database)

#4

Bah… beat me to it :wink:


#5

Thanks for the rapid response!


#6

I tried to install the patch. I placed a copy of the 7.1.3 core folder as “core713”, stopped CF server and renamed the 7.1.0 core folder to “coreOLD” and renamed core713 to “core”. I had to stop the CF server in order to rename the folders. Stopping IIS wasn’t sufficient.

I ran the updateapp using the updatekey and got timeout errors. I went back to the server, stopped CF server and put back the 7.1.0 core. When I ran the updateapp, I got the following error:

An exception occurred while invoking an event handler method from Application.cfc. The method name is: onApplicationStart.

Any ideas? We just rebooted the server and we’re still getting the same error.


#7

If you have stopped CF before updating core then you don’t need to perform the updateapp. The application scope will already be empty so the app will simply start up using the new version of core.

Restart CF again, then just hit the home page and the app should start up fine.

If you have any advance settings like component caching and cached class files turned on in your CF admin then you may need to flush those, just like you would for making any code change in your app?


#8

Thanks justincarter! We restarted CF again and the sites came back online. I thought I had tried just accessing one of the sites without ?updateapp= right after the server re-boot and still got the application error. Anyhow, we’re back to the 7.1.0 core and will save the patch install for another evening.