MySQL not accepting all of the inserts during install

Deployed DEPLOY-mysql_ruleText.sql
Deployed DEPLOY-mysql_ruleXMLFeed.sql
ERROR: INSERT-container-1.sql - Error Executing Database Query.
ERROR: INSERT-container_aRules-1.sql - Error Executing Database Query.
ERROR: INSERT-dmCarouselItem-1.sql - Error Executing Database Query.
ERROR: INSERT-dmCategory-1.sql - Error Executing Database Query.
ERROR: INSERT-dmEvent-1.sql - Error Executing Database Query.
Inserted INSERT-dmEventListing-1.sql
ERROR: INSERT-dmFacts-1.sql - Error Executing Database Query.
ERROR: INSERT-dmHTML-1.sql - Error Executing Database Query.


Can you check that “Enable multiple queries” is checked in the datasource definition you are using?

See Troubleshooting mySQL database installs for more information and troubleshooting.

If that doesn’t help, could you sure a few more details like ACF/Lucee and MySQL version please?



Actually I solved it by downloading and installing a jdbc driver and then using ‘other’ for the dsn connection and adding allowMultiQueries=true to the actual JDBC Url, which was a Ben Nadel suggestion in one of his helpful topics. But now I’m getting cf10 errors when #preserveSingleQuotes(SQL)# shows up in the code… what can I do about that ?

preserveSingleQuotes(SQL) in Install code causing CF10 errors

Is there a work-a-round for this ?

Can you recreate your DSN using the default / built-in MySQL driver? You will need to add the allowMultiQueries=true to the connection string.

If that doesn’t resolve it, maybe also double check that there isn’t some other option in the DSN that affects preserveSingleQuotes(), it does sound familiar but I can’t quite remember of the top of my head…

Are you installing FarCry Core 7.1.1?

I’m installing 7.0, I’ve already tried using the mySQL connector with the added connect string of: allowMultiQueryies=true, but it failed and didn’t allow multiQueries, so I had to install a jdbc connector, which apparently does handle the multi lined queries, but balks on preserveSingleQuotes…

What version of MySQL driver?

7.0 is a little old and there could have been a bug that was fixed. Can you try the latest 7.1.1 release from ?

the cf10 native one just says mySQL(4/5) not sure what version… the jdbc verson is the latest one on