SOLVED! - Problem with buttons not working

Somehow the buttons have stopped working in my Farcry installation.

You can make an attempt to login in this page - and you will see that the login data is not posted at all:

Any suggestions?

Try clearing the www/cache directory

Tried that. Made no difference…

what version of FC 7 are you running?

I’m currently on 7.0.5

Perhaps try the latest from the p700 branch?

If I in the terminal write git status I get

# On branch p700

And then a git pull give me

Already up-to-date.

hmm ok, what web server are you using? Apache? IIS?

It’s a Linux server running Apache (and Tomcat with Railo)

I can add that if I inject a into the login form, then I can use that one to log in. But the buttons within the webtop are still not working…

If you inject what into the form? I think discourse ate the code snippet you put in there

Just tried to submit form after disabling JS in browser and the form submits, I get the “The username or password was incorrect” error message.

Do you have a local development version of this site? If so does this work?


Yeah, it definitely has to be related to javascript, which is why my first suggestion was to clear the www/cache dir, usually that fixes these weird JS bugs. Sometimes loadJs/loadCss corrupts the final output.

Are you overriding any core Javascript libraries (jQuery, bootstrap, etc?)

Have you tried switching off gzip?

Have to investigate a little how to do that :slight_smile:

Ok - I beleive I’ve turned of gzip… still no difference.

I’m not overwriting any core libraries

I made a new git repo and downloaded a fresh copy of the core (p700) - just to be sure that I have the latest, freshest code - and deleted all files in the cashe directory. And still no difference.

As I see it - there should/could not be a problem with the core files - so it must be a server issue of some kind???

I don’t get it at all…


It was the case settings of “Dot notation” in Railo that was set to “Keep original case”.

I set it to “Convert to upper case (CFML Default)” and it works again.