Solr Pro Content Type Administration Error


I want to create a custom content indexing via Solr Plugin and i have selected the following custom fields to be indexed,

but unfortunately i do not know what to select for search result defaults. The documentation example mentions only dmHTML content type that is installed by default.

Afterwards i select label for both search result defaults, i come across the following error:

As far as i can see i have deployed all my COAPI


Additionally i attach you my Solr Pro Plugin config (Admin - General Admin) for a better view


Thanks for all the screenshots. Extra info like that is always helpful.

A few simple questions to help start things:

  1. What are you running on: OS version, IIS/Apache, CF/Lucee/Railo version?
  2. Did you setup your web alias in your web server to use “/farcrysolrpro”?
  3. In the first three screenshots you didn’t add the actual solr field types. Make sure to remember to hit the “+” button to add them.
  4. Once all of this is done, then try indexing your content.

Thanks for the reply!

My working PC is running windows 7, Apache 2.4 and Coldfusion 11. I have already set up the web alias farcrypro and that is obvious via screen “Detailed Installation and Setup Help” (both icons visible).

I tried to index a (simple) custom content type (appealer) and include only 4 properties (string type) as a starting point, despite the fact that i want also to include other properties (similar to country.cfc as custom type and therefore i do not know what to select from the dropdown box for this specific occasion before pressing +). Unfortunately i came across a series of screenshots that would be helpful to attach all of them.


Restart solr and then re-edit and save the FarCry config for the plugin. It hasn’t created the Solr core for some reason. Assuming all your paths are correct it should create one called “Chelsea” (which should match your application name), but since that isn’t there the HTTP requests cannot complete.

In order to restart solr I use cmd
Ctrl + C and afterwards java -jar start.jar. Afterwards admin-General admin-solr pro plugin config and save again the pre populated form data.
How i will get a message that Chelsea core is created or not? Is there another way to create a core without farCry webtop menu only via cmd?


My significant error was that i constantly started solr server as single core (java -jar start.jar) instead of multicore (java -Dsolr.solr.home=multicore -jar start.jar). Is there any documentation on how to work with this specific screen after indexing some content and which webskin to use for testing (type=solr&view=blabla).
Pagination is included by default or i have to play again with skin:pagination ?


After successfully creating an Apache Solr core, i tried to index some custom type content as a starting point (4 only string fields) in order to learn it as much as i can.

Unfortunately i came across the following (error) screenshots:

Regarding solr pro plugin GUI, i have got the following screenshots and i still do not know what is happening wrong


The error is on this function:

<cffunction name="getFTTypeForProperty" access="public" output="false" returntype="string">
    <cfargument name="typename" required="true" type="string" />
    <cfargument name="propertyName" required="true" type="string" />
    <cfset var properties = application.fapi.getContentTypeMetadata(typename = arguments.typename, md = "stProps", default = "") />
    <cfreturn properties[arguments.propertyName].metadata.ftType />

So one of your properties must be missing an ftType attribute in whatever content type you’re attempting to index.

There is a search tool in the webtop menus that you can use to test that your data has been indexed so you can eliminate the front end as a source of your problems.

That’s true! Some of my properties didn’t have got ftType attribute. I fixed them, but still the same problem. Maybe something else is missing?


Did you do an ?updateapp= or restart FarCry via the webtop after you added the ftType attributes?

Thanks for your reply again!

I followed your advice once again but unfortunately the same error turned up. I think that something else is wrong with custom content type. Unfortunately i can not proceed any further.