Simple link to uploaded document using user-supplied text

Apologies in advance. I am sure this info is somewhere, and I can not find it.

I want to simply link to an already uploaded pdf file and be able to edit the text that is linked. I have associated the documents on the page, but when I click the RTF link icon, there is no list of the documents I have uploaded. If I click the FarCry content template icon, I can get the link there, but when I try to change the text of the link in the BODY/RTFcontent area, I have to highlight or backspace over the inserted text (the name of document). By the time I delete the first or last letter, the link is gone. I know how to do this via the source code, but I am looking for an easy solution for the end-user.

well, OK. I tried once more, this time typing my text in the body beforehand, highlighting, THEN going to Farcy content… that worked. So thanks! Hope this helps someone…

What version of FarCry are you using?

It may be that when you initially populate the related content array, FarCry does not properly populate the TinyMCE (Rich Text Editor) drop down for associated files immediately. It’s possible that reloading the edit handler (for example, saving and re-editing or even just reloading the step in the wizard) was enough to correctly update the dropdown.

If you can confirm if this is indeed an issue, and what version of FarCry you are on we’d be most grateful :smile:


The files were in the dropdown box triggered by the TinyMCE icon for FarCry content templates. I was just having trouble getting the file to appear as a link in the TinyMCE body section. I have to type text, highlight it, click FarCry content templates, choose the file, then click the file in Item drop, then ‘download’ in template drop, then OK. It is wokring fine this way; just took me a bit to figure out.