RuleHandPicked: List Selected: Remove One Item

Running FC 6.2.7 - We’ve installed a bunch of “StandAlone” FarCrys on this server and it’s the first time that we’ve had this problem and in all my years of using FC, it’s the first time I’ve encountered this problem.

We’ve got a Utility Handpicked Rule that has been deployed with several skin specifications. The Content Administrators one to remove one object from the middle of the list. They hit the “remove” button, a JS Alert box fires, and then… nothing. Weird right? Usually the item is removed from the selector modal box, the user presses save and presto, FarCry Magic!. The Remove All Button works as expected. I’ve tried editing while monitoring the Firebug Console, but I’m not seeing any errors.

Any tips on what to look for an fix would be deeply appreciated.


Usually I’d say check the Console for JavaScript errors but you’ve already tried that :smile: Are you sure there are also no JS errors prior to clicking the button?

Does the Remove button fail on normal arrays, or does it only fail for the hand-picked rule? All it really does is call the same JavaScript function in both cases so I’d kind of expect them both to work or fail equally. The fcForm.detachLibraryItem() function just hides the item using animation, removes it from the DOM, then updates a hidden field. There’s no ajax or anything else so there isn’t much that can go wrong.

It’s also worth noting that the latest version of 6.2.x is 6.2.10 so you could perhaps try that in a dev environment to see if it resolves the problem:

I don’t think the problem was related to Javascript or Ajax, there was something in the built-in functions within the rule cfc. We ended up basically just comparing code from sites that were working fine with sites that weren’t. Unfortunately, I realized that I didn’t reply to this thread until long (today) after we had gotten it fixed.