REST API plugin and Coldfusion


#1

Hi All,
I’ve run the plugin successfully on Lucee, but I’ve just tried installing it on CF11 and it appears not to like the argument parameters. It would appear that the in=“path” is the main culprit. Perhaps ‘in’ is reserved in CF? What about changing it globally to something like swagger_in … thoughts anyone?



#2

Hey Phil,

We have it running in production on ACF and I think we had the same issue… It looks like we currently have a “coldfusion” branch that has not been merged into master yet. Could you give that a try?

cheers,
Justin


#3

Sweet that seems to have worked :slight_smile:
Also,… Is there any easy way of limiting the fields returned on a list? I’ve extended v1.cfc but the lost seems to just pass an array of objects. There looks like you might be able to add a getAPIResponse method to a type but there isn’t an example of it and I’m not sure if that’s the way to go. I wanting to return a 3 month list of content but limit it to a select few fields.

Phil


#4

The expected getAPIResponse return value should be straight forward - refer
to the rest of the getResponseObject function. There are cases for
preparing various property types for a JSON response struct. Just do the
same for the properties you want to return.

Blair