Problems with bulk image upload


#1

Hello all, individual image uploads on FarCry 7.2.9 work fine. Any time I try to use the bulk image uploader, though, I get an error, “The response object has been recycled and is no longer associated with this facade.” There is a little info button next to the error, but clicking it does not do anything.

The bulk uploader for documents works fine btw.

Any clues on where to start looking? Thanks a lot in advance!


#2

If it helps, I get the same error when trying to use bulk uploader on another site that uses the Chelsea Boots theme. This is for bulk uploads to image library or image gallery, btw.

Both sites are on different subdomains, but the same ACF 2016 server.

Thanks! I have about 300 images to add, and am not looking forward to doing them one at a time! :scream:


#3

Can you try updating to the latest p720 branch from GitHub? We’re overdue
for a release and the latest code might have a fix that will help.


#4

Thanks Justin I will try that. Sorry to ask a dumb question, but this is just core, right? I don’t need to update FarCry CMS or anything? Thanks!


#5

I went ahead and dropped in the latest core from GitHub, and am still getting the same error. Any thoughts?


#6

On a lighter note, though, updating core seems to have completely resolved the web feed problems I had in a previous thread. Everything is working fine now, with unmodified core webskins! Thanks for the tip!


#7

I am trying to fix this on my own, but to be honest, I do not even know where to start looking. I found something on tracker.adobe.com about a similar error introduced in a cfthread block. I’m happy to give it a try but I have no idea what I should be looking at. The bulk file uploader has its own separate files, but I don’t see anything similar for the bull image uploader.

Any more suggestions are greatly appreciated!

BTW if it helps, the original image is initially uploaded to the server, but it errors out immediately after and never gets processed into FarCry CMS. No standard or thumbnail images are generated and nothing is saved in the image library. Nothing is added to dmImage table either.

Thanks everybody!


#8

Bulk upload does use threads to handle processing asynchronously, but I’ve
never seen that error before. The thread is created in
core/packages/lib/tasks.cfc and the processing is done in
core/packages/events/bulkupload.cfc.


#9

Thanks Blair, I appreciate the help! I will take a look – I am quite sure I can break it even more!:joy:


#10

Okay, I am at my wit’s end with this. I am still getting "The response object has been recycled and is no longer associated with this facade” on any bulk image upload. The image actually does upload, and in fact a dmImage folder and Source Image folder are created, but it never gets past that. No standard, no thumbnail, and of course nothing shows in image library after that.

To try and make sure it wasn’t something dumb I had done, I:

  1. Installed a clean bare bones on a different subdomain – same error
  2. Installed a clean Chelsea Boots on a different subdomain – same error
  3. Installed clean Chelsea Boots on totally different domain – same error
  4. Installed clean bare bones on a vm on my laptop – same error

Does the bulk image uploader actually work for anybody? If so, please let me know – it will help me stay motivated to keep trying to fix this! :grinning: Many thanks!


#11

Hi,
Just to confirm it works; (my servers are all Linux)
Works on a CF11 ent server running 7.2.8

But…
I’ve just tested 2 sites running on lucee 4.5.
7.2.9 site worked
7.2.10 site didn’t

I updated the 7.2.9 site to 7.2.10 and the bulk upload failed. Reversed it and it worked again.

There is a log file called bulkupload.log that will show any errors.
In my case I was getting
Could not handle /amping-58.jpg: Expected file does not exist [/srv/www/mysite/htdocs/WEB-INF/lucee/temp/amping-58.jpg]
That file did actually exist in the temp folder but is was called Amping-58.jpg

This makes me think it may be a casing issue in cdn.cfc.