No login on webtop - new dev CF11


Let’s update OSX to the latest version, what could possibly go wrong…

Famous last words from yours truly before realising the latest Apple OS update included an update on Apache. It’s taken some time to get back up and running again but I’m running again on Apache > CF11 but when I try to login to webtop it throws me back to the login again.

I have seen this before but I can’t remember how I fixed it. Have anyone else seen this and can think of a quick fix to try?



It's usually related to cookies I think. Log in to the CF Administrator, change the cookie type to CFML, then clear your cookies and try logging in again?

This is another one of those moments where I call myself a dork. I just cleared the cookie and it worked fine.

Thanks mate! :slight_smile:

1 Like

No worries :wink: Often it can be triggered after changing the cookie type - if cookies of the other type were previously set it gets itself in a right mess…

I’ve also seen strange session related things happen if you are just logged in on “localhost” (CF10+), or if you happen to start a site on a particular host name, then stop it and run another site on the same hostname and the cookies are still set in the browser from the previous app… Nightmare!

That makes sense, thanks mate.

just don’t change cookie type on production as we are using clustered cookies so needs to be type cfml :slight_smile:

Make sure you have j2ee sessions enabled I the CF admin

in a previous email Justin said to set to CFML - fix cookie issue
Does this mean it should be set back to J2EE once cookie issue has been resolved??

Leave your cookies alone if everything is working :) My answers above were specifically related to fixing someone's dev machine.

It's fine to use either CFML or J2EE cookies depending on what you need to achieve in your specific environment. FarCry should have no specific requirement for you to choose one over the other, AFAIK.