Login screen appears when going to Site tab

I have a site using FarCry 6.2.7 . It’s on a server with other sites that are sharing the same farcry core. I’m able to login to the site, however, when I click on the “Site” tab, I get the login screen in the main iframe. I’m still logged in and can access the admin for the site pages.

I tried checking the “Use J2EE session variables” box in the CF Admin, but this made the issue worse. I can login fine, but clicking on the “Content” or “Admin” tab would log me out and return me to the login screen.

None of the other sites on this server have this issue.

Anyone know how to fix this issue?


  • JR

Certainly sounds like a strange outcome. FarCry webtop will automatically log you out if you hit a view that it believes you don’t have permission to see. Might be worthwhile double checking that the roles you are logging in under don’t accidentally have a problem with something you are trying to render in the tree view.

FarCry 7+ webtop is a complete overhaul of the tree ui – would be interesting to see if you had a similar problem in an upgraded environment, or if at least it gave more of an indication of what’s triggering the logout.

This sort of thing tends to be a ColdFusion session issue rather than anything to do with FarCry. FarCry should happily work with either CF or J2EE sessions; we typically recommend J2EE where possible. I’d recommend ensuring that you don’t have any cookies that might reflect an old session on the domain; mixing CF and J2EE sessions often leads to corrupt sessions that can be fixed by a cookie purge.

Hope that helps.

Is there a good documentation resource on the customadmin.xml file? We’ve had a little bit of success modifying a different tab to have the content frame resolve to something specific, but are having a hard time achieving the same trick for the Site Tab.

As luck would have it:

Though there are a few new things since the 7.0 release that are not well documented; for example, now you can invoke a view directly by nominating the typename and the body view.

Is the problem only happening on your PC? Have you tried clearing your cookies or using a different browser?
Or is it only happening for your user account and not other accounts? If it’s permission related, you could check the Role that is related to your account (the Role which matches the Groups your account belongs to) and see if the Webtop permissions need to be adjusted.

It might also be worth checking your projects /config/_serverSpecificRequestScope.cfm to see if there is any code in there that is doing something funny with the session.

Normally if you are denied access to something in the webtop you will see a login screen saying you don’t have permission to view a page, but you shouldn’t actually be logged out (try hitting the webtop URL again straight away to confirm). If your session is really gone then it might point towards something like a very short session timeout for that application (check your farcryConstructor.cfm).

phillepanto fixed the issue by modifying the local customadmin.xml file. The XML below stopped the login screen from appearing when clicking the “Site” tab after logging in.

<section sequence="2"  permission="MainNavMyFarcryTab"  mergeType="replace" id="site" >
  <subsection id="tree" sequence="100" sidebar="site/sidebar.cfm" content="site/index.cfm" label="Site" />