Inconsistent problems with ACF2018 and core p740

Hello all, I am running the 740 core on ACF2016 without issue. When trying to run it under ACF2018 though, sometimes it works, sometimes it does not. There does not seem to be any pattern.

Restarting the CF server itself, however, will reliably trigger a crash. Said crash produces tons of these entries (every few seconds) in exception.log:

“Error”,“ajp-nio-”,“12/14/21”,“12:17:23”,“NEWSITE”,"Object Instantiation Exception… The specific sequence of files included or processed is C:\home\\wwwroot\farcry\core\packages\farcry\combine\combine.cfc, line: 48

After a while, it will magically start working again, until the whole process starts over, seemingly at random.

I do use the Solr plugin, and the FarCry CMS plugin. I will note that this error only occurs on one particular site. Another site, also running 740 core and on the same instance of CF2018, does not have these problems.

Also, apps not running under FarCry CMS, but on the same domain, do not have these problems. In other words, will crash, while will be fine.

I know this is not much to go on, but if anybody has any suggestions or advice, I sure would appreciate it. Thanks!

What version of the java jvm are you running on?

Thanks Sean, 2018 uses 11.0.7.

I have a dev env on FC p740, CF 2018 updated to hotfix 11, openjdk 11.0.10_9. It works consistently for me. Maybe this can help you figure out if a CF update or a different JDK version would fix the issue for you.

That said, I have seen that same error in the combine.cfc before when I was attempting to upgrade another of my client’s sites to p740. I don’t recall if I was able to work around it or fix it, and I don’t recall the exact setup as far as versions of CF, JDK, etc. I had to move onto some other work so I never completed that upgrade (I’ll be coming back to it in the next few weeks though).

If you do manage to find a solution please post back in here in case I run into it again when I attempt the upgrade later.

Thanks a lot Shawn, I will try some different things out. I will note again that a pretty straightforward Chelsea Boots site, running on p740 and the same instance of CF 2018, does not have any problems.

This one site, though… ugh!!! :slight_smile:

Thanks for your help!

You really shouldn’t have to do this, but try adding these paths to your java classpath either in your jvm.config file or via the CF admin (adjust to match where you have farcry’s core files)


Doing this, I was able to get past the error (I’m running on ACF 2021 though) but now I’m hitting another issue where CF seems to think that there is no driver or URL to access my SQL server datasource even though it verifies just fine in the CF admin. Not sure what is going on there. I’ll have to investigate it further tomorrow. If you get the same error, let me know. Here is what I get:

java.sql.SQLException: No driver or URL found. at coldfusion.server.j2ee.sql.pool.JDBCPool.createPhysicalConnection( at coldfusion.server.j2ee.sql.pool.ConnectionRunner$ at java.base/

at cfApplication2ecfc837722830$funcONAPPLICATIONSTART.runFunction(/var/www/farcry/core/Application.cfc:394)

Hi Sean, many thanks! This seems to have done the trick, at least as having the running site survive a restart of CF.

I edited the jvm.config as you advised, restarted CF, and spun up my FarCry site, which worked fine! Then, I restarted CF, which previously would guarantee a crash. But this time it worked! I did not get any errors at all in fact. Very nice. Many many thanks!

I will keep an eye on it, but again, no errors in the CF 2018 exception log.

I am getting an error in the webtop when I try to navigate to Developer Utilities / COAPI Content types, though. I am not too worried about this, as it is likely unrelated, but FYI all the same. Here is the error:

“The value returned from the isFieldAltered function is not of type boolean.”

"If the component name is specified as a return type, it is possible that either a definition file for the component cannot be found or is not accessible.

Tag Context:

\wwwroot\farcry\core\packages\dbgateways\BaseGateway.cfc (line: 910)
\wwwroot\farcry\core\packages\lib\db.cfc (line: 803)
\wwwroot\farcry\core\webskin\farCOAPI\webtopBody.cfm (line: 296)
\wwwroot\farcry\core\webskin\farCOAPI\webtopBody.cfm (line: 249)
\wwwroot\farcry\core\webskin\farCOAPI\webtopBody.cfm (line: 1)
\wwwroot\farcry\core\packages\fourq\fourq.cfc (line: 422)
\wwwroot\farcry\core\packages\fourq\fourq.cfc (line: 310)
\wwwroot\farcry\core\tags\webskin\view.cfm (line: 140)
\wwwroot\farcry\core\tags\webskin\view.cfm (line: 76)
\wwwroot\farcry\core\tags\webskin\view.cfm (line: 11)
\wwwroot\farcry\core\tags\webskin\view.cfm (line: 9)
\wwwroot\farcry\core\tags\webskin\view.cfm (line: 1)
\wwwroot\farcry\core\webskin\types\webtopPageStandard.cfm (line: 16)
\wwwroot\farcry\core\packages\fourq\fourq.cfc (line: 422)
\wwwroot\farcry\core\packages\fourq\fourq.cfc (line: 310)
\wwwroot\farcry\core\tags\webskin\view.cfm (line: 140)
\wwwroot\farcry\core\tags\webskin\view.cfm (line: 76)
\wwwroot\farcry\core\tags\webskin\view.cfm (line: 11)
\wwwroot\farcry\core\tags\webskin\view.cfm (line: 9)
\wwwroot\farcry\core\tags\webskin\view.cfm (line: 1)

Looking at isFieldAltered I’m not sure how that could ever return a non-boolean. Odd error.

What type of database are you using? MySQL? SQL Server?

After adding the paths to the classpath, I was able to get past that initial error but now I’ve run into an issue now where no matter what I do, any interaction with the database inside the FarCry application throws an error so FarCry is unable to initialize. However, if I setup a subdirectory with its own Application.cfc and its own application name, then I can use <cfquery> and other database interactions just fine so the database and the ColdFusion datasource is setup fine, but when running in the context of the FarCry application it throws the error. It is so odd. I’m not sure what FarCry could be doing that would cause this, but, again, I’ve had to put this on hold to work on some other work.

If it is any help, our application is running fine now, thanks to your help. All of our own code runs against our databases fine, and I can run searches from within the webtop using the Solr Pro plugin. Searches on our regular website work fine as well, and of course all of our queries seem to work fine. Sorry I cannot be of any more help!

To answer your question, we are using MySQL 5.7.1, and I have not noticed any of the issues described in this thread.