Does FarCry Core and the CMS plugin support OpenBD?

Hello All,

I just wanted to know if the latest version of FarCry and it’s CMS plugin support the OpenBD cfml engine. It looks like FarCry did or aspired to support OpenBD at one time, but from looking at documentation online I cannot tell if it still does.

Please let me know.


1 Like

As far as I know it only supports Adobe CF and Railo, but wait for someone from Daemon to chime in for an official response.

The last time I tried to test on OpenBD was more than 12 months ago and
there were some compatibility issues with the installer. Since then FarCry
7 has been released with a brand new installer, so the previous issues may
not apply but I haven’t actually tested it yet.

So the short answer is “no”, it’s not supported, but I’d be happy to
investigate it again and/or accept pull requests on GitHub for any patches

I had a quick look…

The FarCry 7 installer runs, but the app can’t start up.

Initially there’s some simple conflicts with flush() and abort() in cfFunctionWrappers.cfm. These can be removed.

Then there are errors initialising the security component. OpenBD throws a pretty vague error on a cfparam in security.cfc:23, “Can’t perform this operation on these data types” (it’s just initialising a struct key with an empty struct).

<cfparam name="application.permission.#stPermission.aRelatedtypes[i]#" default="#structnew()#" />

I’ve worked around that by replacing it with a check for structKeyExists and a structNew();

<cfif NOT structKeyExists(application.permission, stPermission.aRelatedtypes[i])>
	<cfset application.permission[stPermission.aRelatedtypes[i]] = structNew()>

Then I get a very generic error with no stack trace… “Expression Error”, “Data not supported”.

That could take a little while to debug the root cause, but I can’t spare the time this morning. If anyone else wants to help please let me know :smile: