dmInclude - > FarcrySolrPro

I am finally getting my FC 6.2.8 site off a Win2k3/CF8. The biggest hurdle for me was getting Solr working…

I finally have everything going, but I am having a problem testing things our creating a farcrysolrpro include.

Following Jeff & Sean’s instructions here:

I get a 500 server

Could not find the included template /farcry/projects/my_project/includedObj/… The specific sequence of files included or processed is D:\sites\my-project\farcry\core\tags\webskin\include.cfm, line: 46

<cfinclude template="#attributes.template#">

I have the following dmInclude record:

croth_CMIAD	2015-07-27 16:37:15.267	2015-07-27 16:47:27.923	displayPage1Col	NULL	Solr	croth_CMIAD	True	croth_CMIAD	6976AC40-34B8-11E5-BC77005056B07592	7C2282F0-004A-11DE-B899005056B02320	approved	NULL	NULL	Solr	NULL	solrProSearch	displayTypeBody

farcrySolrPro is my only “plugin” based include… my regular file based includes seem to work.

Not sure if I have a plugin issue, or a migration issue.

Any hep or pointers appreciated.


Are you getting this error when you bring up the window to add a new include object? If yes, perhaps you just need to create the empty folder “includedObj” under your project (not sure - I usually have that folder anyway - even though it’s blank). You may need to updateapp after creating it.

If you’re not getting an error on the “add” screen, are you getting an error when oyu hit save? If yes, are you selecting option 1 (to use a content type and view)? If not, make sure you are since that is what the instructions you’re referring to call for.

Hi Jeff.

I chose option 1 I get the error when I try to preview the include.

Everything else seems to be working. I can use the test option under the plugins admin in webtop


Did you try my first suggestion?

I do have an includedObj folder under my main project. It have a number of _myfiles.cfm … included non farcry apps.

I honestly do t know (not near a computer at the moment) - could be something in FacrCry. Maybe try upgrading to FC 6.3.2?

Have you extended dmInclude in any way? Usually it should store the full path to the included object, e.g. /farcry/plugins/someplugin/includedObj/filename.cfm

I think this is how it has worked since FC5, maybe earlier. I think FC3 stored the filename only.

Try re-saving the include in the tree?

Actually, I don’t think FarCry SOLR Pro uses any includedObj files… Are you sure the error is related to that DB record / FarCry SOLR Pro plugin?

Make sure option 2 is blank (or set to none or whatever). It’s possible you have it set to an old setting/file. Thus when you save the include object it could be looking for the old file and failing.

If that isn’t it, try deleting the include in the tree and then recreating it.

dmProfile was extended, looks like some time way back I wanted the title to be nstring vs. string (we have some asian double byte stuff going on) but I removed the file re-init/coapi, etc…

I deleted the include, recreated, made sure option 2 was ‘none’… .here’s the DB record:

croth_CMIAD	2015-07-28 16:59:13.087	2015-07-28 16:59:34.947	displayPage2Col	NULL	SolrTest	croth_CMIAD	0	NULL	A55B56D0-3584-11E5-B4E6005056B07592	7C2282F0-004A-11DE-B899005056B02320	approved	NULL	NULL	SolrTest	NULL	solrProSearch	displayTypeBody

Same error in CF Admin.

Could not find the included template /farcry/projects/www_project_com/includedObj/.. The specific sequence of files included or processed is D:\sites\www-project-com\farcry\core\tags\webskin\include.cfm, line: 46

I should point out that this 6.2.8 FC site has been brought up from … Atleast 4.0 if not earlier!.. anywhere else I might look for something that may have been customized outside of core?.. Like I mentioned, my other includes wok but they are the includedObj type…

Thanks guys!

Okay, that error has to do with the “layout template” (nothing to do with the solr pro plugin). The file it is looking for is called displayPage2Col.cfm. That file needs to either live in [project]/webskin/dmInclude, [project]/webskin/types, or one of the same webskin folders in a loaded plugin.

My guess is that you had the file at one point and deleted it.

Change the template (in the dropdown) to something else that exists and that should fix it (hopefully :smile: ). If an old file is still appearing in the dropdown that you know no longer exists, make sure you do an updateapp first (if that doesn’t help, make sure you have correctly named them at the top of each webskin file with <!--- @@displayname: [Some Text Here] --->.

Is this literally the error message with no modifications? (There is a “dot” but no filename? I’m assuming the second “dot” is meant as a full-stop in the context of the error message)

Could not find the included template /farcry/projects/www_project_com/includedObj/…

The line referenced in the stack trace (D:\sites\www-project-com\farcry\core\tags\webskin\include.cfm, line: 46) is the <cfinclude> line below:

	<cfif NOT findNoCase("/", attributes.template)>
		<cfset attributes.template = "/farcry/projects/#application.projectDirectoryName#/includedObj/#attributes.template#" />
	<cfinclude template="#attributes.template#">

The only reason this code executes is because it is getting called from \core\webskin\dmInclude\displayBody.cfm, which is the <skin:include> line below:

<cfif structKeyExists(stobj, "webskinTypename") AND structKeyExists(stobj, "webskin") AND len(stobj.webskinTypename) AND len(stobj.webskin)>	
	<skin:view typename="#stobj.webskinTypename#" webskin="#stobj.webskin#" stInclude="#stobj#" />
<cfelseif len(stobj.include)>
	<!--- USE skin:include tag to include the file. --->
	<skin:include template="#stObj.include#" />

The only reason skin:include is called is if your dmInclude (stObj) is missing the webskinTypename or webskin properties or one of them has no length, AND if your stObj.include property has a length… And that doesn’t seem to be the case based on the DB row you’ve pasted above…

Can you check to see if your project has overridden webskin\dmInclude\displayBody.cfm for some reason?

If that doesn’t uncover anything, then I think to debug it further you’ll need to cfdump stObj on line 27 of \core\webskin\dmInclude\displayBody.cfm possibly followed by a cfabort (to avoid an error page being displayed).

Let me know how you go :smile:

Hi Guys… thanks again for the help. I finally figured it out… sometime… in like 2008 (file last updated), I overrode the way dmIncludes were handled… via project/types/displayheaderstandard.cfm… I don’t know why… but i am having to clean up 7+ years of hacks… might have been better off rebuilding the site from scratch on a fresh 7.x install… appreciate the help… I will be back …


1 Like