[closed] FC 7.2.8 - Image upload - Error IO: undefined

#1

Hi,

trying to upload an image to the FarCry Image Library with a fresh “Firefox 48.0.2” installation results in an “Error IO: undefined”. Doing the same with “Chrome 53.0.2785.113 m” Browser everything works correctly and the image is added to the Image Library.

I have this special problem with the Firefox browser already for a long time. It seems that it has nothing to do with the Firefox version or the FarCry version. Normally I use Firefox, but I always have to use Chrome if I want to upload images to the Image Library. That sucks…

Do you have a helpfull hint for me ?

#2

Hi Knut,

I’ve just done a test with FarCry Core 7.2.8 and Firefox 42.0.1 and the images uploaded and cropped successfully;

It’s quite strange that it’s working in Chrome but not Firefox. I think I’ll need more info to help troubleshoot…

  1. Are there any JavaScript errors in the developer console?
  2. In the “Network” tab of the developer console, can you see the ajax response that contains the error message? Can you provide the whole response?
  3. Are there any errors in your CF/Railo/Lucee logs? If so, can you provide them?
  4. Does your Firefox settings have a proxy configured and Chrome doesn’t?
  5. Do you have some antivirus software running that could be affecting network requests?
  6. Do file uploads fail in Firefox when you use other sites / apps? e.g. Gmail, TinyPNG (https://tinypng.com/), or something else that lets you upload images?

There aren’t many hits when searching for “Error IO: undefined” on Google, but there are some related to Uploadify… Most suggestions are to check that either some folders exist or that the correct permissions have been applied to them – but if uploads work in Chrome then that shouldn’t be the cause.

https://www.google.com.au/search?q=farcry+error+IO+undefined&oq=farcry+error+IO+undefined&aqs=chrome..69i57j69i60.6984j0j7&sourceid=chrome&ie=UTF-8#q="error+IO:+undefined"

Hopefully you can rule out or confirm a few things, that might get us closer to solving it :slight_smile:

cheers,
Justin

#3

Hi Justin, (sorry for my English)

thank you for helpfull hints. I did a lot of investigation in a VM with a fresh Windows 7 and Firefox installation. The result was the same and the error was still there, but no errors were reported in the developer concole. In the “Network” output I saw, that the processing stopped after the first “Post XHR”:

POST XHR https://www.mydomain.de/webtop/facade/ftajax.cfm?/ajaxmode/1/formtool/Image/typename/dmImage/fieldname/fc1E9D1B607B3311E69328000C2995D0A8SourceImage/property/SourceImage/objectid/1E9D1B60-7B33-11E6-9328000C2995D0A8/check/1 [HTTP/1.1 200 OK 143ms]

At least I’ve tested without using the SSL connection and everything worked fine !

Because the customer has no SSL cert for his website (not needed), I use a self-signed cert, for a SSL secured webtop login. In Firefox I’ve added this self-signed cert as an permanent exception. Normally this should work in Firefox, but in the case of image uploads in FarCry it does not work.

At the moment I have no idea how to solve this problem. :smirk:

#4

That makes sense, if the upload is happening via Flash then perhaps the Flash Player doesn’t trust the certificate. You could perhaps try to install the cert using the Internet Options dialog in IE, like this:

https://helpx.adobe.com/flash-player/kb/flash-player-issues-secure-sockets.html

Otherwise you may have to stick to Chrome or install a certificate that is not self-signed?

#5

Importing the self-signed cert to the trusted cert store via Internet Options dialog in IE solved the problem.
Thx for your help.

1 Like
#6

I think we’re still using Flash for uploads in core, so the Firefox
exception may not be helping.

Blair