Carousel and footer etc

hi, have just installed Farcry with Lucee and probably a stupid question but I can’t seem to find where to reference or link to the farcry logo on the top left of the homepage or the carousel also on the homepage. I can’t seem to find the footer either. I can see and edit the body content of the Home, getting started, typography pages etc ok. Does the reflected containers option have anything to do with this? as that page returns an error of ‘key [CONTAINER] doesn’t exist’

Its been a while since I looked at the example project that FarCry uses but the carousel is likely a “Rule” which can be edited from the front end. Log into the webtop, then visit the front end of the website. You’ll see the FarCry tray at the bottom of the page. On the right side of that tray look for the “Rules” button and turn that on. This will show you all the containers on the page and any rules inside them. You can edit the rules that are there, remove them, or add new ones.

The header and footer are likely static files. You’ll find these in /farcry/projecst/yourprojectname/webskins/types/display(Header|Footer)Standard.cfm

Hi, I found the header and footer Ok thanks but where the tray is supposed to be at the bottom of the page it says:
‘That page could not be found
Please push “back” on your browser or go back home’

Any ideas on how to get the tray linked properly again?

the tray looks like this

No, the tray is not displaying. It is saying ‘That page could not be found Please push “back” on your browser or go back home’.
I clicked on repair refObjects but it doesn’t make any difference.
If I click on on ‘Rules & Containers’ under ‘Content’ and then ‘Reflected Containers’ I get an error message: ‘key [CONTAINER] doesn’t exist’
I am using 7.4.0 of FarCry Core and Lucee Version: if that is any help.

I have not encountered this particular issue with FarCry, but maybe similar with other apps where there is significant sever and JavaScript interaction.

Try this: check and if necessary set the Lucee Admin / Language/Compiler / Key Case to Preserve Case. Then restart Lucee to force a complete application rebuild.


Tried that with the language compiler but still the same issue.

Can you use your browser’s console or network tool to see what URL is giving a 404?

It should look something like this:

/index.cfm?typename=dmHTML&objectid=< some object id >&view=trayContainer&ajaxmode=1&totalTickCount=448

Try to open that URL in its own browser tab and make sure that it works. If you get a 404 perhaps you have an issue with permissions. For example, if you created your own user group and granted it permissions to log into the webtop but you didnt’ grant it access to view the “trayContainer” webskin than FarCry’s permissions system would give you a 404.

Are you using the built-in security groups or did you create your own?