Bulk upload temp file location


#1

(FC7+S3) Where are the temp files stored on the bulk upload for images and files?

The bulk uploading is not completing uploads at the moment and when I cancel it and return to the file list, it’s imported a couple of images from the previous upload. A broad assumption might be there is some old files stuck in a temp folder?


#2

Are you having problems with bulk uploading files (as opposed to images)? There was a very recent fix that went into the p700 maintenance branch that may be of interest:


#3

Just updated to the latest p700. Still the same.

It gets stuck on “Queued for processing” and doesn’t continue. Then when you hit “Save and continue” it returns to the list and there’ll be an image from a previous bulk upload showing as updated a minute ago.


#4

The bulk upload does use a queue in the background for processing. You can probably find out by looking at the tools in the Webtop:

  • your previous tests are blocking up the queue (see Webtop -> Admin -> Developer Tools -> Task Queue -> Queued Jobs)
  • the threads working through the queue have crashed (see Webtop -> Admin -> Developer Tools -> Task Queue -> Threads)
  • you don’t have enough threads for the workload you’re testing with (see Webtop -> Admin -> General Admin -> Application Settings -> Config -> Task Queue) - keep in mind that this is also affected by the thread limit of your CFML engine

Blair


#5

Ahhhh, yes. There were a crap load of jobs sitting in there. I think we may have had some impatience going on with some users in processing.

I’ve cleared them all out and tried again and it’s processing now. Having said that it is taking a long time. The first two took about 20-30 seconds but the next 3 are still going 10 mins on.

The files are largish but not ridiculous, 1200x800 and around 700-900 KB. Delay could be in the uploading to S3?


#6

Not sure if this is related but the task that is stuck, although new is saying Latest Task Processed as 45 years ago, rotating between 44 and 45 every couple of seconds.


#7

Accessing files on S3 will add overhead, since the app needs to download the image then process the various cuts and upload them. The date issue may be a bug related to tasks not having been started - depending on the DB, FarCry will sometimes store null dates as 1 Jan 1970. There should be some options for getting more detail in the dropdown next to the job. Specifically, you should be able to view errors from there.

Blair