5.2.7 to 7.1.1 Upgrade

Hello again.
Mostly all good and 7.1.1 is awesome on my clean insytall.
However on a v5.2.7 upgrade it works fine, and the webtop is all good, except the Admin link tab.
All tabs work but Admin tab results in this error…
Any specific known issue this is caused by?

Element TYPENAME is undefined in STDATA.
Exception Type: Expression 
Tag Context: E:\farcry\core\webskin\farConfig\displayCellEditLink.cfm (line: 7)
E:\farcry\core\packages\fourq\fourq.cfc (line: 452)
E:\farcry\core\packages\fourq\fourq.cfc (line: 338)
E:\farcry\core\tags\formtools\objectadmin.cfm (line: 1124)
E:\farcry\core\tags\formtools\objectadmin.cfm (line: 1120)
E:\farcry\core\tags\formtools\objectadmin.cfm (line: 839)
E:\farcry\core\tags\formtools\objectadmin.cfm (line: 823)
E:\farcry\core\tags\formtools\objectadmin.cfm (line: 743)
E:\farcry\core\tags\formtools\objectadmin.cfm (line: 178)
E:\farcry\core\tags\formtools\objectadmin.cfm (line: 1)
E:\farcry\core\webskin\farConfig\webtopBody.cfm (line: 80)
E:\farcry\core\packages\fourq\fourq.cfc (line: 452)
E:\farcry\core\packages\fourq\fourq.cfc (line: 338)
E:\farcry\core\tags\webskin\view.cfm (line: 140)
E:\farcry\core\tags\webskin\view.cfm (line: 76)
E:\farcry\core\tags\webskin\view.cfm (line: 11)
E:\farcry\core\tags\webskin\view.cfm (line: 9)
E:\farcry\core\tags\webskin\view.cfm (line: 1)
E:\farcry\core\webskin\types\webtopPageStandard.cfm (line: 16)
E:\farcry\core\packages\fourq\fourq.cfc (line: 452)

UPDATE from CF dumps

CFC[ E:/farcry/core/packages/lib/esapi.cfc | onMissingMethod(Element TYPENAME is undefined in STDATA.) ] from E:/farcry/core/packages/lib/esapi.cfc

It’s not an issue we’re aware of. What CFML engine are you using? Am assuming you have run an ?updateall=<projectkey> to deploy any missing COAPI changes.

Yes updateall=key
ColdFusion 9
Interestingly enough, I went back to that site (there are 7 we are migrating) later, and it worked.
Everything puled together except plugins.

With 7 sites please understand when I have more questions. they are all different, but with the same core so it is somewhat straightforward, with twists for each site.


Be sure to let us all know what you’ve been up to when you’re done :wink: Post a few screenshots and a couple of words to the builtwith catagory.

Will do, several are very easy and the rest are very hard.
Original v4 mollio so its along streatch into todays v7.1.1 but generally speaking , with a little ehelp from the farcry dev teams knowledge base ( :slight_smile: ) it is going well.

5 sites perfect 2 sites still arguing.
One of them shows this issue.
Where is the fapi being defined to pass?

08:41:24.024 - Expression Exception - in E:/farcry/core/tags/navajo/display.cfm : line 51
Element FAPI is undefined in a Java object of type class [Ljava.lang.String;.

I have two sites of the five fail on this initial upgrade.
Is there any way to brute force the upgrade I am missing?

Unknown tag: farcry:farcryInit

Where is this tag located?
I have searched everywhere for it.

That tag would have been deprecated quite a few versions ago. Which file is calling that tag?

In newer version of FarCry (FC5+) the project will contain an Application.cfc which extends the one from core, and the application startup happens in there without the use of any tags, I think. The project should also have an index.cfm which just calls <nj:display>.

You can see examples of these two files in the barebones project skeleton:

A full stack trace of the error might also be helpful in working out what the problem is :smile:

Yes that’s good news. But when I remove the call for it it complains that fapi doesn’t exist or application doesn’t exist depending upon how I remove it.
Good news it isn’t a valid tag tho!

So close 5 working sites and two buggers.
Hope this falls together in the morning or I have to go split it and leave these two v4.
Work em later

And this is in the application.cfm before the upgrade. It causes the fails.
But if I take either out it says the above with FAPI or application missing.

<cfimport taglib="/farcry/core/tags/farcry/" prefix="farcry" />
	plugins="" />

You’ll need to remove the Application.cfm from your project (that approach isn’t supported since around FC4), and instead use the Application.cfc, index.cfm and farcryConstructor.cfm.

You can probably copy all of the files from the “barebones” project skeleton /www folder into your projects webroot folder, and then just be sure to set up your new farcryConstructor.cfm with all the appropriate settings:

Thanks Justin,
But these are version 4 sites.
When I do that I receive this
Element FAPI is undefined in a Java object of type class [Ljava.lang.String;.

Any thoughts on what that is?
These sites were built many years ago in a land of mollio.
I have no documentation to see what is internal and what is farcry.

The application.fapi error is happening because your application isn’t starting up.

Perhaps FC4 is the last version where the Application.cfm worked. In FarCry 7.x you’ll need to upgrade your project to use a Application.cfc + farcryConstructor.cfm + proxyApplication.cfc + download.cfm + index.cfm.

If you look at the example files in the /www of the “barebones” project skeleton you should be able to copy them into your project and then customise the farcryConstructor.cfm with all of your settings, then delete the old Application.cfm.

You might also need to restart CF in case the application was already initialised by the old Application.cfm.